Настройка сетевого оборудования

Материал из RSU WiKi
Перейти к: навигация, поиск
Pen.pngЭта статья находится в процессе написания.
Если вы считаете, что её стоило бы доработать как можно быстрее, пожалуйста, скажите об этом.
Tower of babel.png外國 language!
В статье используется несколько языков. Необходимо использовать один. Совсем неплохо, если это будет русский.

Содержание

3Com

3com Superstack II 1100

  • Скорость 1200 / 2400 / 4800 / 9600 / 19200
  • Размер символа 8
  • Чётность NONE
  • Стоповые биты 1

3com Superstack 3 4250

  • Автовыбор скорости
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности

3com Superstack 3 4400

  • Автовыбор скорости
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности

Все набираемые в cli команды можно сокращать до размера, когда они не начнут пересекаться с другими командами, напр. pro > ip > int равносильно protocol > ip > interface

Reset to factory defaults Перейдите в меню system > control > initialize. Для подтверждения введите: yes.

Поиск по mac-адресу

bridge > addressDatabase > find
00-00-00-00-00-00

ip-адрес свитча Перейдите в protocol > ip > interface

Для просмотра текущего адреса используйте команду:

summary

Обзор осуществляется при выборе:

all

Смена адреса одного из интерфейсов выполняется мастером, вызываемым командой:

modify

Для настройки статического адреса выберите:

manual

Далее введите требуемые адрес, маску и номер управляющего vlan:

Enter IP address  [192.0.2.2    ]: 192.0.2.3
Enter subnet mask [255.255.255.0  ]: 255.255.255.0
Select management VLAN ID(1,25)[25]: 25

Cisco

Основная статья: Cisco

D-Link

Просмотр системной информации и текущих сетевых настроек:

show switch

Конфигурация ip-адреса и маски подсети:

config ipif System ipaddress xxx.xxx.xxx.xxx/yyy.yyy.yyy.yyy

или :

config ipif System ipaddress xxx.xxx.xxx.xxx/z

DES-3526

Доступ по RS-232:

  • 9600 baud
  • no parity
  • 8 data bits
  • 1 stop bi

Сохранение конфигурации:

DES-3526:admin#save
Command: save

Saving all configurations to NV-RAM... Done. 

Просмотр vlan`ов:

DES-3526:admin#show vlan

Создать vlan:

DES-3526:admin#create vlan <vlan_name> tag <vlan_id>

Добавить порты в vlan:

DES-3526:admin#config vlan <vlan_name> add (tagged | untagged) <port_list>

Удалить порт из vlan`а:

DES-3526:admin#config vlan <vlan_name> delete <port_list>

Удалить vlan:

DES-3526:admin#delete vlan <vlan_name>

Запретить порт в vlan`е:

DES-3526:admin#config vlan <vlan_name> add forbidden <port_list>

DWL-3260AP

Attention.pngВНИМАНИЕ!
Web-интерфейс данного устройства доступен только через Internet Explorer

По умолчанию (после hard reset) точка настроена следующим образом:

адрес: 192.168.0.50
логин: admin
пароль: (оставьте пустым)

Ноутбук или ПК для настройки можно настроить следующим образом:

адрес: 192.168.0.2
маска: 255.255.255.0
шлюз: 192.168.0.1
Attention.pngВНИМАНИЕ!
Настройки применятся только после выполнения пункта Configuration > Save and activate
  • Настройки подключения к локальной сети находятся в Basic Settings > LAN. Задайте адрес, маску и шлюз, нажмите Save. После смены адреса на точке не забудьте дать адрес ноутбуку в той же подсети.
  • Беспроводная сеть настраивается в меню Basic Settings > Wireless. Для настройки свободной нешифрованой зоны выберите следующее и нажмите Save:
mode: access point
Wireless Network Name (SSID): example.com
В блоке Key Settings:
 Encryption: Disable
  • Пароль администратора задается в меню Tools > Administrator Settings в разделе Login Settings. Задайте старый пароль, новый и подстерждение. Нажмите Save.
  • Для применения настроек и перезагрузки нажмите Configuration > Save and activate

HP ProCurve

HP V1905-8-PoE Switch (JD877A)

Характеристики:

  • Серийный номер: JD877A (бывший 3CRDSF9PWR)
  • Порты: 8+1
  • PoE: Есть

Настройки RS-232:

  • 38,400 baud (bits per second)
  • 8 data bits
  • no parity
  • 1 stop bit
  • no hardware flow control

Default login password:

  • At the login prompt, enter admin as your user name and press Return.

The Password prompt displays.

  • At the Password prompt press Return.

Просмотр vlan:

Console#show vlan id <vlan_id>

Настройка свитча:

Пароль администратора (по умолчанию admin):

Console(config)#username <admin> password 0 <password>

Создание vlan:

Console(config)#vlan database
Console(config-vlan)#vlan <vlan_id> name <vlan_name> media ethernet state active

Удаление vlan:

Console(config)#vlan database
Console(config-vlan)#no vlan <vlan_id>

Добавление портов в vlan:

Console(config)#interface ethernet <unit>/<port_list>
Console(config-if)#switchport allowed vlan add <vlan_list> tagged

<port_list> - номер порта, несколько портов через запятую,диапазон через тире. <vlan_list> - список портов через запятую.

Удаление портов из vlan:

Console(config)#interface ethernet <unit>/<port_list>
Console(config-if)#switchport allowed vlan remove <vlan_list>

Адрес свитча:

Console(config)#interface vlan <vlan_id>
Console(config-if)#ip address 192.168.1.5 255.255.255.0

Шлюз по умолчанию:

Console(config)#ip default-gateway 192.168.1.1

Сохранение текущей конфигурации:

# This example shows how to copy the running configuration to a startup file.
Console#copy running-config startup-config
Startup configuration file name [startup1.cfg]:
Write to FLASH Programming.
Write to FLASH finish.
Success.

Сброс на заводские настройки/Reset to factory defaults

  1. Перезагрузите свитч (выключите и включиите питание)
  2. Дождитесь сообщения о вводе Ctrl + C в течение 5 секунд для перехода в Fallsafe mode
  3. Выберите пункт password recovery

HP V1905-24-PoE Switch (JD992A)

Документация HP V1905-24-PoE Switch Через консоль настраивается управляющий vlan, управляющие порты и ip-адрес, а через web-интерфейс полноценно настриваются все vlan'ы, пароль администратора и пр.

Важно! Ограничение на длину пароля 8 символов.

Настройки RS-232:

  • 38,400 baud (bits per second)
  • 8 data bits
  • no parity
  • 1 stop bit
  • no hardware flow control

HP Procurve 2626

  • Любая скорость от 1200 до 115200
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности
  • управление потоком установить в Xon/Xoff

Для Windows Terminal также выключите (снимите метку) “Use Function, Arrow, and Ctrl Keys for Windows” (Использовать функциональные кнопки, стрелки, кнопки Ctrl). Для Hilgraeve HyperTerminal выберите вариант “Terminal keys” для параметра “Function, arrow, and ctrl keys act as”

HP Procurve 2510

  • Любая скорость от 1200 до 115200
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности
  • управление потоком установить в Xon/Xoff

Для Windows Terminal также выключите (снимите метку) “Use Function, Arrow, and Ctrl Keys for Windows” (Использовать функциональные кнопки, стрелки, кнопки Ctrl). Для Hilgraeve HyperTerminal выберите вариант “Terminal keys” для параметра “Function, arrow, and ctrl keys act as”

HP Procurve 5304

  • Любая скорость от 2400 до 115200
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности
  • управление потоком установить в None

Для Windows Terminal также выключите (снимите метку) “Use Function, Arrow, and Ctrl Keys for Windows” (Использовать функциональные кнопки, стрелки, кнопки Ctrl). Для Hilgraeve HyperTerminal выберите вариант “Terminal keys” для параметра “Function, arrow, and ctrl keys act as”

Просмотр vlan`ов на порту:

show vlans ports <ports_list>

Установка пароля (CLI)

Set operator and manager password

password all

SSH / SSL (https)

По инструкции http://xgu.ru/wiki/Доступ_к_коммутатору_ProCurve

SSH

configure
crypto key generate ssh
ip ssh

Перезаходим по SSH и:

configure
no telnet-server
wr mem

SSL (https)

configure
crypto key generate cert 1024
crypto host-cert generate self-signed
  • Validity start date [01/01/1970]: MM/DD/YYYY
  • Validity end date [MM/DD/YYYY+1]: MM/DD/YYYY+5
  • Common name [0.0.0.0]: sw0.example.com
  • Organizational unit [Dept Name]: IT Dpt
  • Organization [Company Name]: Ryazan State University
  • City or location [City]: Ryazan
  • State name [State]:
  • Country code [US]: RU
web-management ssl
no web-management plaintext
wr mem

DHCP Snooping

Порядок настройки DHCP snooping

  1. Настройка и проверка работы DHCP-сервера и DHCP-ретранслятора без включенного DHCP snooping.
  2. Включение DHCP snooping. После включения DHCP snooping на коммутаторе и в соответствующих VLAN, все порты коммутатора по умолчанию считаются ненадёжными.
  3. Указание доверенных портов. Те порты к которым подключены коммутаторы и которые ведут к DHCP-серверу (или порты к которым сервер подключен) должны быть настроены как доверенные.
  4. Настройка политики обработки опции 82 (см. настройку DHCP Relay ниже).
  5. (Опционально) Включение или выключение дополнительных проверок DHCP-сообщений.

Покажем работу с DHCP-Snooping на примере 5304xl. Перепрошиваем до E.10.61 или выше.

Заходим в нужный раздел в cli:

ProCurve(config)# config

Включить:

ProCurve(config)# dhcp-snooping

Выключить:

ProCurve(config)# no dhcp-snooping

Добавить порт, на котором сидит DHCP-Server (например, 8й порт модуля A):

ProCurve(config)# dhcp-snooping trust A8

Указать VLANы, для которых настроено (VLAN 2):

ProCurve(config)# dhcp-snooping vlan 2

Состояние:

ProCurve(config)# show dhcp-snooping

Записать конфигурацию во flash-память свитча, чтобы она подхватилась после перезагрузки:

ProCurve(config)# write memory

DHCP Relay (Option 82)

Настройка на примере коммутатора L3 Procurve 5304xl. Имеем основной VLAN (ID 16) где находится dhcp-сервер, и клиентские VLAN'ы (ID 20). Предполагается, что коммутатор настроен в режиме маршрутизатора и имеет ip-адреса в каждом из VLAN'ов (192.0.2.1/25 и 192.0.2.129/25). Адрес DHCP-сервера 192.0.2.2.

В консоли Procurve пишем следующее:

# configure
# dhcp-relay option 82 keep 
# vlan 20
# ip helper-address 192.0.2.2

На DHCP сервере разрешаем на firewall'e соединения с адресом 192.0.2.129

В настройках named.conf в самом верху пишем (это поможет при анализе логов и настройке правил):

if exists agent.circuit-id {
    log (
        info, concat( "Lease for ", binary-to-ascii (10, 8, ".", leased-address), " is connected to interface ",
        binary-to-ascii (10, 8, "/", suffix ( option agent.circuit-id, 2)), " (add 1 to port number!), VLAN ",
        binary-to-ascii (10, 16, "", substring( option agent.circuit-id, 2, 2)),  " on switch ",
        binary-to-ascii(16, 8, ":", substring( option agent.remote-id, 2, 6))));

    log (
        info, concat( "Lease for ", binary-to-ascii (10, 8, ".", leased-address),
        " raw option-82 info is CID: ", binary-to-ascii (10, 8, ":", option agent.circuit-id), " AID: ",
        binary-to-ascii(16, 8, ".", option agent.remote-id)));
}

Маршрутизация

Как просмотреть существующие маршруты?

 show ip route

Маршрутизацию между Vlan'ами L3-коммутатора и сетью, находящейся за роутером внутри одного из vlan'ов прописываем на примере Procurve 5304xl следущим образом:

ip route 198.51.100.xxx  255.255.255.224 192.0.2.1

где:

  • 192.51.100.ХХХ - удаленная подсеть
  • 192.0.2.1 - адрес роутера, в одном из vlan'ов коммутатора

чтобы удалить маршрут, пишем:

no ip route address/mask

ZyXEL

ZyXel ES-2008

  • Скорость 9600
  • 8 бит данных
  • 1 стоповый бит
  • нет чётности
  • Управление потоком - none

Пароль по умолчанию

login: admin
password: 1234

Пароль пользователя admin

sysname(config)#admin-passowrd <pwd-string> <confirm-string>

Factory reset

  • Если cli свитча доступен через telnet или RS-232

Resets the Switch to the factory default settings:

sysname# erase running-config

Сохранить настройки

sysname# write memory
  • Если cli не доступен через telnet или RS-232

Например, пропало питание во время сохранения настроек через web-интерфейс. Решение протестировано на свитче Документация по ZyXEL ES-2024A.

ATUR - загрузка прошивки по протокололу X-modem
ATLC - команда принимает файл конфигурации по протокололу X-modem
ATGO - перезагрузка

Что нужно сделать:

  • Скачать прошивку
  • Подключиться через гипертерминал и войти в Debug mode (можно перезагрузить свитч, если гипертерминал настроен, но ничего не происходит)
  • Если свитч не прошит последней прошивкой, что использовать ATUR и передать файл bin по протоколу X-modem
  • Начать прием файла командой ATLC и передать файл .rom по протоколу X-modem
  • Установка и перезагрузка выполняется командой ATGO

После перезагрузки долго инициализируется, но, в итоге, предлагает авторизоваться.

IP-configuration Просмотр текущей конфигурации сетевых интерфейсов по vlan`ам осуществляется командой:

sysname# show ip

Задать ip адрес свитча в требуемом vlan`е можно из меню configure перейдя командой vlan <vlan id> в требуемый vlan. IP-адрес задается командой ip address <address> <mask>. Например:

sysname# configure
sysname(config)# vlan 1
sysname(config-vlan)# ip address 192.0.2.2 255.255.255.0

Задать основной шлюз можно в меню configure командой ip address default-gateway <address>:

sysname(config)# ip address default-gateway 192.0.2.1

System information Общую системную информацию можно просмотреть командой:

sysname# show system-information

Имя свитча задается в меню configure командой:

sysname (config)# hostname <name_string>

Контактное лицо и расположение в системной информации задается командой:

sysname (config-vlan)# snmp-server contact <system-contact> location <system-location>

Здесь <system-contact> и <system-location> указываются без пробелов, хотя в документации указано обратное. Пример:

sysname (config-vlan)# snmp-server contact Person_Name location B1F1A1R

VLAN Просмотр текущей конфигурации vlan`ов выполняется командой:

sysname# show vlan <vlan id>

Если параметр <vlan id> опустить, то будет выведена информация о всех существующих vlan на свитче.

Создание или редактирование vlan происходит в меню configure. Команда vlan <vlan id> открывает для изменения существующий vlan или создает новый, если <vlan id> не используется:

sysname# configure
sysname (config)# vlan <vlan id>

В меню конфигурации имя текущего vlan задается командой:

sysname (config-vlan)# name <name_string>

Для создания статического vlan следует указать порты, принадлежащие vlan как постоянно принадлежащие этому vlan. Это делается командой:

sysname (config-vlan)# fixed <port-list>

В списке подряд идущие порты указываются через дефис, а остальные через запятую. Тегированные порты задаются командой no untagged, а нетегированные - untagged. Стоит запретить командой остальным портам быть в составе этого vlan:

sysname (config-vlan)# forbidden <port-list>

Выход из меню конфигурации vlan осуществляется командой:

sysname (config-vlan)# exit

После конфигурации состава портов на vlan`е для них нужно задать pvid. По стандарту IEEE 802.1Q когда на свитч приходит тегированный трафик, а pvid совпадает с идентификатором пакета vlan id, то тег удаляется из пакета. Если идентификатор пакета vlan id не совпадает с pvid, но является разрешенным на этом порту, т. к, например, он входит в состав нескольких vlan`ов, то тег не удаляется.

Для заданных портов настройка pvid проводится в меню configuration командой:

sysname (config)# interface port-channel <port-list>

PVID задается командой:

sysname (config-interface)# pvid <vlan-id>

В соответствии со стандартом IEEE 802.1Q назначаем нетегированным портам pvid равный vlan id, а тегированным - номер default_vlan.

Рассмотрим пример создания статического vlan с vlan id 2000, в состав которого входят нетегированные порты 5-8 и тегированный порт 26 на свичте 24+2:

sysname (config)# vlan 2000
sysname (config-vlan)# name example
sysname (config-vlan)# fixed 5-8,26
sysname (config-vlan)# forbidden 1-4,9-25
sysname (config-vlan)# no untagged 26
sysname (config-vlan)# untagged 5-8
sysname (config-vlan)# exit
sysname (config)# interface port-channel 5-8
sysname (config-interface)# pvid 2000
sysname (config-interface)# exit
sysname (config)# interface port-channel 26
sysname (config-interface)# pvid 1
sysname (config-interface)# exit
Attention.pngВНИМАНИЕ!
На свитчах ZyXEL не забывайте следить что бы на нетегированных портах pvid совпадал с vlan id, в составе которого они находятся.

Подключение адаптера RS-232 на контролере PL-2303 в Mac OS X

Attention.pngВНИМАНИЕ!
Выполнение инструкций этого раздла потребует перезагрузку. Да, на маке О.о
PL-2303 USB-to-Serial Bridge Controller от Defender

В этом разделе описано подключение PL-2303 USB-to-Serial Bridge Controller в Mac OS X.

Драйвер контроллера для контроллера PL-2303

Драйвер может быть загружен отсюда: http://www.prolific.com.tw/US/ShowProduct.aspx?p_id=229&pcid=41

Установка minicom для Mac OS X

minicom устанавливается по ссылке в статье http://pbxbook.com/other/mac-tty.html

После установки драйвера и minicom

После установки драйвера и minicom, делаем следующее:

  • Находим новое устройство в /dev при подключении переходника. Название начинается с tty.XXX (например tty.usbserial)
ls /dev | grep tty
  • minicom ставится по умолчанию в /opt/bin/minicom. Первый запуск выполняем с ключом -s (/opt/bin/minicom -s) и правим настройки порта, а также пишем туда появившееся устроство из /dev
    • Настройки порта задаем в разделе Serial port setup
    • Сохраняем как настройки по умолчанию пунктом Save setup as dfl

Пример настроек для HP 5406 zl

   │ A -    Serial Device      : /dev/tty.usbserial                        │
   │ B - Lockfile Location     : /tmp                                      │
   │ C -   Callin Program      :                                           │
   │ D -  Callout Program      :                                           │
   │ E -    Bps/Par/Bits       : 115200 8N1                                │
   │ F - Hardware Flow Control : No                                        │
   │ G - Software Flow Control : No                                        │
   │                                                                       │
   │    Change which setting?                                              │
  • делаем симлинк из /opt/bin/minicom в /usr/bin
sudo ln -s /opt/bin/minicom /usr/bin
  • Профит!

Программы для подключения по RS-232

Этот способ подключения к управляемым свитчам, модемам и др. сетевому оборудованию наряду с веб-интерфейсом и telnet, но при условии что последние 2 способа недоступны (не задокументирован статический ip, отсутствует сеть из-за неправильной конфигурации и т. п.). Так же только при подключении через RS 232 можно сбросить забытый пароль на некоторых моделях свитчей. Ниже приведены типичные настройки клиентов для оборудования, используемого в РГУ им. С. А. Есенина.

Скорость 1200 / 2400 / 4800 / 9600 / 19200

Это поле позволяет вам выбрать правильную скорость передачи данных для вашего терминала или модема. Если вы включили автоопределение, скорость будет выбрана автоматически.

Размер символа 8 

Это поле показывает размер символа данных для вашего свича. Вы должны установить такое-же значение в терминале.

Чётность NONE 

Это поле показывает настройки чётности для вашего свича. Вы должны установить такое-же значение в терминале.

Стоповые биты 1 

Это поле показывает настройки стопового бита для вашего свича. Вы должны установить такое-же значение в терминале.


HyperTerminal

Minicom

Основные ключи для указания количества бит в секунду и используемого устройства:

minicom -b <bps> -D <rs232_device>
At work clipart.pngЭто незавершённая статья, требующая доработки.
Переписать раздел о minicom'e со скриншотов на консольный вызов с необходимыми параметрами через ключи. Это более быстрый и удобный способ при необходимости вести работы с большим кол-вом оборудования.


Для настройки свитча в Linux используется программа minicom.

Сначала необходимо выяснить какой порт дает usb2serial перходник:

dmesg | grep ttyUSB

Выяснив это, запускаем minicom с необходимыми параметрами, например:

minicom -b 9600 -D /dev/ttyUSB0

Appendix A: Как найти подключенное устройство по mac-адресу?

Часто в больших сетях бывает необходимо выяснить, к какому коммутатору и в какой порт подключено то или иное устройство. Рассмотрим, как это можно выяснить на примере следующего сетевого оборудования.

ProCurve 5304xl

В telnet-сессии набираем:

show mac-address 82:D2:00:00:20:05 

и получаем результат:

Status and Counters - Address Table - 82d200-002005

MAC Address : 82d200-002005
Located on Port : A8

В случае, если mac-адрес неизвестен заранее, пингуем интересующий адрес прямо со свитча:

ping 172.16.0.2

Смотрим таблицу ARP:

sh arp

3Com 4500

Переходим в режим:

system-view

В telnet-сессии набираем:

display mac-address 82D2-0000-2005

См. также

Ссылки

Личные инструменты
Пространства имён

Варианты
Действия
Навигация
Инструменты